Help! Installing MAMP + CF8 on Leopard

Ok, some help needed here:

I have a brand new Mac Pro at work; Running the latest and greatest version of OSX with all the security updates etc.

So I need to install CF locally, and have already installed MAMP.
MAMP I got working with no problems, and running on the default ports for MySQL + Apache.

Installed CF8, 64bit edition, and when installing, did the single server instance. I can’t remember if I specified the built in webserver, or tried to point it to MAMP, but post installation, I had nothing in the web server config, so set up the web server connector as follows:

jrun Host: localhost
jrun Server: ColdFusion
Web Server: Apache
Configuration Directory: /Applications/MAMP/conf/apache
Configure web server for ColdFusion 8 Applications: ticked

And in Advanced:

Enable verbose logging for connector: unticked
Enable native OS memory allocator: unticked
Build Apache module from source using APache eXtenSion tool: unticked
Directory and file name of server binary: /Applications/MAMP/bin/apache2/bin/httpd
Directory and file name of server control script: /Applications/MAMP/bin/apache2/bin/apachectl

Now, when I try and start MAMP, mySQL runs, but Apache itself won’t start.
I’ve checked that CF has written the appropriate lines into the http.conf file, which it has – it’s added the .cfm extensions etc.

When I try and start Apache via Terminal, I get this:

Syntax error on line 1114 of /Applications/MAMP/conf/apache/httpd.conf:
Cannot load /Applications/ColdFusion8/runtime/lib/wsconfig/1/mod_jrun20.so into server: cannot create object file image or add library

“mod_jrun20.so” does exist in that location.

Any ideas what to try next?

**update**
Now solved! – installed the 32bit version instead of the 64bit version, as MAMP ain’t got enough bits. 🙂
Thanks to Stephen Erat!